Skip to main content

Author Topic: lendacademy web server problems

  • *****
  • Hero Member
  • Posts: 604
lendacademy web server problems
OP: October 09, 2016, 11:00:00 PM
Frequently over the past week, I get a 404 not found error message when attempting to view a page on the lendacademy forum.  Clicking refresh fetches the page (usually), but sometimes I have to wait a few minutes, after which a refresh will work.

Here's one of the messages...
<html>
<head><title>404 Not Found</title></head>
<body bgcolor="white">
<center><h1>404 Not Found</h1></center>
<hr><center>nginx</center>
</body>
</html>
  • IP logged

R
  • Posts: 484
lendacademy web server problems
#1: October 09, 2016, 11:00:00 PM
Ditto
  • IP logged

L
  • Posts: 241
lendacademy web server problems
#2: October 09, 2016, 11:00:00 PM
Same here.
  • IP logged

T
  • Posts: 6588
lendacademy web server problems
#3: October 16, 2016, 11:00:00 PM
Getting worse I think.  The outages each last about 1 minute.  I see a few every day, but I'm not always using the web site, so I suspect there are dozens of them every day.
  • IP logged

Z
  • Posts: 119
lendacademy web server problems
#4: October 16, 2016, 11:00:00 PM
Thanks everyone for pointing this out. I will look into this further.
  • IP logged

T
  • Posts: 6588
lendacademy web server problems
#5: October 16, 2016, 11:00:00 PM
Yeah, there is something going on. Maybe a DoS attack  :)
But seriously, there are problems with the server I've not seen before.
Becoming a real PITA.
  • IP logged

T
  • Posts: 6588
lendacademy web server problems
#6: October 17, 2016, 11:00:00 PM
Some additional observations...

1. During one of these outages, I can ping the lendacademy web server. 

2. I have only noticed the outages while reading the forum, but during one of the outages I tried to access the main lendacademy web page.  It also timed out.  In other words, during the outage, all web pages are down, not just the forum.

3. The symptom is always a long delay (must be a timeout of some kind) followed by a 404 message from your server.  Because we get the 404 message, the browser is not timing out.  Something internal to the web server is timing out.

4. The 404 message we get is not your customized 404 message, but appears to be the default nginx 404 message.  I tried intentionally accessing a nonexistant page, something like www.lendacademy/forum/nonexistentpage.htm and that fails with a nice 404 message containing a lendacademy logo etc.

My guess is that your web server becomes unable to access the files that contain the web site content.  Perhaps a file system is going offline, or communication with a back-end server is being lost.
  • IP logged

R
  • Posts: 12
lendacademy web server problems
#7: October 17, 2016, 11:00:00 PM
Hi all, we've made some changes on the hosting side. If you continue to notice issues please let us know. Thanks!
  • IP logged

r
  • *****
  • Hero Member
  • Posts: 575
lendacademy web server problems
#8: October 18, 2016, 11:00:00 PM
It just happened to me.
  • IP logged

T
  • Posts: 6588
lendacademy web server problems
#9: October 18, 2016, 11:00:00 PM
Ditto, 2 min. or so ago.  I copied my post before I lost it and started the process over.  Fine now.
  • IP logged

T
  • Posts: 6588
lendacademy web server problems
#10: October 18, 2016, 11:00:00 PM
Just happened to me again (twice in a row); the 404, nginx problem.
  • IP logged

T
  • Posts: 6588
lendacademy web server problems
#11: October 18, 2016, 11:00:00 PM
Thanks for the heads up. We are continuing to work on this.
  • IP logged

T
  • Posts: 6588
lendacademy web server problems
#12: October 19, 2016, 11:00:00 PM
I observed one of these outages Thur morning 10/20 12:38AM PST (may have started earlier) to about 12:41:30AM.

This is the first time I've written down the times.  I watched it for over 3.5 minutes! 
  • IP logged