P2P Forum

Lending Club Discussion => Investors - LC => Topic started by: dompazz on March 26, 2016, 11:00:00 PM

Title: API Latency
Post by: dompazz on March 26, 2016, 11:00:00 PM
This has been mentioned recently, but I feel it deserves its own topic. 

Latency in the API around the note releases has become appalling.  I'm seeing 10-20+ second times to request new loans.  Orders are taking more than 5-15 seconds to process and confirm.  What times are you seeing?

I wrote a note to LC earlier in the week and got this reply Friday afternoon:

Quote
Title: API Latency
Post by: Fred93 on March 26, 2016, 11:00:00 PM
Thank you for hitting them. 

I see same.  Some commands >20 seconds.   

I will note that the long delays are only near feeding times.  The problem is therefore some sort of server congestion at feeding time.  Maybe somebody missed a schedule date to upgrade some piece of the server network?  As volumes grow, they have to keep upgrading.

Commands have always been slower at feeding times, but not this slow.  Also in the past, the slowdown was only within a few seconds of feeding time.  Now its slow within the minute around feeding time.
Title: API Latency
Post by: TravelingPennies on March 26, 2016, 11:00:00 PM
from: Fred93 on March 27, 2016, 07:13:50 PM
Title: API Latency
Post by: MarinBB on March 27, 2016, 11:00:00 PM
from: dompazz on March 27, 2016, 06:40:17 PM
Title: API Latency
Post by: RaymondG on March 27, 2016, 11:00:00 PM
from: MarinBB on March 28, 2016, 07:54:57 AM
Title: API Latency
Post by: TravelingPennies on March 27, 2016, 11:00:00 PM
Anyone else notice that the physical location of the API's IP address changed to a data center in Las Vegas? The main site still seems to be somewhere around Santa Monica. Maybe they moved some of their systems to a different data center and introduced some latency in the process.

I used https://www.iplocation.net/ to check api.lendingclub.com and www.lendingclub.com.
Title: API Latency
Post by: TravelingPennies on March 27, 2016, 11:00:00 PM
from: MarinBB on March 28, 2016, 07:54:57 AM
Title: API Latency
Post by: TravelingPennies on March 31, 2016, 11:00:00 PM
It looks like that the speed of Browse Notes page on LC web site was back to normal at feeding times since at least yesterday.
Title: API Latency
Post by: TravelingPennies on March 31, 2016, 11:00:00 PM
API behavior is back to normal also.
Title: API Latency
Post by: TravelingPennies on April 04, 2016, 11:00:00 PM

from: dompazz on March 27, 2016, 06:40:17 PM
Title: API Latency
Post by: dms on April 07, 2016, 11:00:00 PM
Slightly off topic, but is there a secret handshake or undocumented documentation for using the LC API?

I'm a new LC investor and am having problems with getting the API to work as documented. I suspect that I'm passing my credentials in the HTTP header properly because when I don't pass them (or deliberately typo) I get a 401 not authorized. With it, I get a 404 not found. I'm using the investor id given off the account summary page as documented and v1 of the api. (account number changed to protect the innocent) Any suggestions from people who are successfully using the API?

I would expect this to return 200, but I get 404 instead -

https://api.lendingclub.com/api/investor/v1/accounts/12345678/summary
Title: API Latency
Post by: TravelingPennies on April 07, 2016, 11:00:00 PM
nm, figured it out. WCF5.5/OData3 != json.
Title: API Latency
Post by: TravelingPennies on April 07, 2016, 11:00:00 PM
I remember lots of trial and error when I went thru this, not just with LC, but every damn web API I've ever used.  What you've written looks correct, so the error is not immediately obvious to me.